debops.hwraid

HWRaid is a repository of software packages useful on hosts with hardware RAID storage arrays for Debian and Ubuntu Linux operating systems.

This role will configure the APT repository for supported distributions and after checking list of loaded kernel modules, install recognized packages. HWRaid packages contain a monitoring script, which will periodically send a mail message to root account in case of issues with the RAID array.

Some of the software packages offered in HWRaid repository are not Open Source, however there are no alternatives available.

Installation

This role requires at least Ansible v1.7.0. To install it, run:

ansible-galaxy install debops.hwraid

Role variables

List of default variables available in the inventory:

---

# OS distribution used to lookup available releases
hwraid_distribution: '{{ ansible_distribution }}'

# OS release used to lookup available releases
hwraid_release: '{{ ansible_distribution_release }}'

List of internal variables used by the role:

hwraid_register_release

Authors and license

debops.hwraid role was written by:

License: GPLv3